Browse Models Failed to list models

Bugs found in the software/hardware

Browse Models Failed to list models

Postby Bob » Mon Aug 24, 2015 9:05 am

After I had downloaded an svg file from Slic3r and converted it successfully I started a trial print, with no resin in vat to check functionality. Everything appeared to be good. It was a large model (778 mins print time) so I decided to change to another model to try some more test prints. Browse models failed to show a list and the iBox seemed to reboot.

How can I delete the file without being able to access the browse list?

I found the following error log.

util.pump() is deprecated. Use readableStream.pipe() instead.

/home/pi/ibox/ibp_browse.js:948
function loadLocal1(response, myBrowseList, isMgntLocal) {
^
RangeError: Maximum call stack size exceeded

I can email you a copy of the svg file if it helps, size was 574KB.

Please advise.

Bob
Bob
 
Posts: 5
Joined: Mon Aug 24, 2015 8:53 am

Re: Browse Models Failed to list models

Postby Xios1306 » Mon Aug 24, 2015 9:52 am

On the advanced settings page there is a button to reset the browse page. Its called reset browse list.
Let me know if that fixes it.
Harsha B C
Intern - Computer Engineer
harsha@iBoxPrinters.com
            iBox Printers
┌───────────────────┐
│██   ██   ██   ██   ██   ██  \
│  ██   ██   ██   ██   ██   ██  \
│   ▀▀   ▀▀   ▀▀   ▀▀   ▀▀   ▀▀ │
│   ▄▄   ▄▄   ▄▄   ▄▄   ▄▄   ▄▄ │
│  ██   ██   ██   ██   ██   ██  /
│██   ██   ██   ██   ██   ██  /
└───────────────────┘
             you make it
User avatar
Xios1306
iBox Pro User
 
Posts: 174
Joined: Wed Jun 03, 2015 12:15 pm

Re: Browse Models Failed to list models

Postby Bob » Mon Aug 24, 2015 10:09 am

No change after reset. Same error message.
Bob
 
Posts: 5
Joined: Mon Aug 24, 2015 8:53 am

Re: Browse Models Failed to list models

Postby Bob » Mon Aug 24, 2015 10:55 am

Original svg file which I think caused problem was 1272KB not 574KB as I previously stated.
Bob
 
Posts: 5
Joined: Mon Aug 24, 2015 8:53 am

Re: Browse Models Failed to list models

Postby Bob » Mon Aug 24, 2015 12:15 pm

Please confirm SAMBA is installed on the Raspberry pi and the full directory name where the model files are located. I hope to use PUTTY to remove the suspect file.
Bob
 
Posts: 5
Joined: Mon Aug 24, 2015 8:53 am

Re: Browse Models Failed to list models

Postby Xios1306 » Tue Aug 25, 2015 5:09 pm

The user name is pi and the password is raspberry
The models are stored in the /home/pi/ibox/www/packages/expanded directory.
Harsha B C
Intern - Computer Engineer
harsha@iBoxPrinters.com
            iBox Printers
┌───────────────────┐
│██   ██   ██   ██   ██   ██  \
│  ██   ██   ██   ██   ██   ██  \
│   ▀▀   ▀▀   ▀▀   ▀▀   ▀▀   ▀▀ │
│   ▄▄   ▄▄   ▄▄   ▄▄   ▄▄   ▄▄ │
│  ██   ██   ██   ██   ██   ██  /
│██   ██   ██   ██   ██   ██  /
└───────────────────┘
             you make it
User avatar
Xios1306
iBox Pro User
 
Posts: 174
Joined: Wed Jun 03, 2015 12:15 pm

Re: Browse Models Failed to list models

Postby Bob » Fri Aug 28, 2015 1:36 am

I removed the suspect directory with the svg images. This did not solve the problem. I did a full restore but still had the problem. I uploaded another svg (about 100KB), did a print run closed the printer and restarted. The browse models function was restored.

Thank you for the directory information.
Bob
 
Posts: 5
Joined: Mon Aug 24, 2015 8:53 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 0 guests

cron